stream_transform v0.0.20 was released a few days ago. It deprecates all its methods in favor of extensions.

But extensions are not usable as of yet, as explained in this article:

In a future release, the Dart language is adding a new feature, extension methods

Indeed, when I tried to install this version, it complained that my version of Dart wasn't high enough yet. How ironical.

$ flutter packages get
Running "flutter pub get" in project...
The current Dart SDK version is 2.6.0-dev.0.0.flutter-1103600280.

Because flashcards depends on stream_transform >=0.0.20 which requires SDK version >=2.6.0 <3.0.0, version solving failed.
pub get failed (1)
exit code 1